参考文献
RFC
- Rescorla, E. "The Transport Layer Security (TLS) Protocol Version 1.3". RFC 9846, 2026. https://datatracker.ietf.org/doc/html/rfc9846
- Rescorla, E. "The Transport Layer Security (TLS) Protocol Version 1.3". RFC 8446, 2018. https://datatracker.ietf.org/doc/html/rfc8446
- Thomson, M. "Example Handshake Traces for TLS 1.3". RFC 8448, 2019. https://datatracker.ietf.org/doc/html/rfc8448
- Cooper, D. et al. "Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile". RFC 5280, 2008. https://datatracker.ietf.org/doc/html/rfc5280
- Shirey, R. "Internet Security Glossary, Version 2". RFC 4949, 2007. https://datatracker.ietf.org/doc/html/rfc4949
- Krawczyk, H., Eronen, P. "HMAC-based Extract-and-Expand Key Derivation Function (HKDF)". RFC 5869, 2010. https://datatracker.ietf.org/doc/html/rfc5869
- Krawczyk, H., Bellare, M., Canetti, R. "HMAC: Keyed-Hashing for Message Authentication". RFC 2104, 1997. https://datatracker.ietf.org/doc/html/rfc2104
- Song, JH. et al. "The AES-CMAC Algorithm". RFC 4493, 2006. https://datatracker.ietf.org/doc/html/rfc4493
- McGrew, D. "An Interface and Algorithms for Authenticated Encryption". RFC 5116, 2008. https://datatracker.ietf.org/doc/html/rfc5116
- Nir, Y., Langley, A. "ChaCha20 and Poly1305 for IETF Protocols". RFC 8439, 2018. https://datatracker.ietf.org/doc/html/rfc8439
- Langley, A., Hamburg, M., Turner, S. "Elliptic Curves for Security". RFC 7748, 2016. https://datatracker.ietf.org/doc/html/rfc7748
- Eastlake 3rd, D. "Transport Layer Security (TLS) Extensions: Extension Definitions". RFC 6066, 2011. https://datatracker.ietf.org/doc/html/rfc6066
- Salowey, J., Turner, S. "IANA Registry Updates for TLS and DTLS". RFC 8447, 2018. https://datatracker.ietf.org/doc/html/rfc8447
- Laurie, B., Langley, A., Kasper, E. "Certificate Transparency". RFC 6962, 2013. https://datatracker.ietf.org/doc/html/rfc6962
- Laurie, B., Messeri, E., Stradling, R. "Certificate Transparency Version 2.0". RFC 9162, 2021. https://datatracker.ietf.org/doc/html/rfc9162
- Saint-Andre, P., Hodges, J. "Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)". RFC 6125, 2011. https://datatracker.ietf.org/doc/html/rfc6125
- Saint-Andre, P., Salz, R. "Service Identity in TLS". RFC 9525, 2023. https://datatracker.ietf.org/doc/html/rfc9525
- Ghedini, A., Vasiliev, V. "TLS Certificate Compression". RFC 8879, 2020. https://datatracker.ietf.org/doc/html/rfc8879
- Thomson, M., Turner, S. "Using TLS to Secure QUIC". RFC 9001, 2021. https://datatracker.ietf.org/doc/html/rfc9001
- Barnes, R. et al. "Delegated Credentials for TLS and DTLS". RFC 9345, 2023. https://datatracker.ietf.org/doc/html/rfc9345
- Rescorla, E. et al. "TLS Encrypted Client Hello". RFC 9849, 2026. https://datatracker.ietf.org/doc/html/rfc9849
- Kwiatkowski, K. et al. "Post-Quantum Traditional (PQ/T) Hybrid Key Agreement Mechanisms for TLS 1.3". RFC 10024, 2026. https://datatracker.ietf.org/doc/html/rfc10024
- Turner, S. et al. "Elliptic Curve Cryptography Subject Public Key Information". RFC 5480, 2009. https://datatracker.ietf.org/doc/html/rfc5480
- Josefsson, S., Schaad, J. "Algorithm Identifiers for Ed25519, Ed448, X25519, and X448 for Use in the Internet X.509 Public Key Infrastructure". RFC 8410, 2018. https://datatracker.ietf.org/doc/html/rfc8410
- Freier, A., Karlton, P., Kocher, P. "The Secure Sockets Layer (SSL) Protocol Version 3.0". RFC 6101, 2011. https://datatracker.ietf.org/doc/html/rfc6101
- Dierks, T., Allen, C. "The TLS Protocol Version 1.0". RFC 2246, 1999. https://datatracker.ietf.org/doc/html/rfc2246
- Dierks, T., Rescorla, E. "The Transport Layer Security (TLS) Protocol Version 1.1". RFC 4346, 2006. https://datatracker.ietf.org/doc/html/rfc4346
- Dierks, T., Rescorla, E. "The Transport Layer Security (TLS) Protocol Version 1.2". RFC 5246, 2008. https://datatracker.ietf.org/doc/html/rfc5246
- Turner, S., Polk, T. "Prohibiting Secure Sockets Layer (SSL) Version 2.0". RFC 6176, 2011. https://datatracker.ietf.org/doc/html/rfc6176
- Barnes, R. et al. "Deprecating Secure Sockets Layer Version 3.0". RFC 7568, 2015. https://datatracker.ietf.org/doc/html/rfc7568
- Moriarty, K., Farrell, S. "Deprecating TLS 1.0 and TLS 1.1". RFC 8996, 2021. https://datatracker.ietf.org/doc/html/rfc8996
NISTの資料
- NIST. "Advanced Encryption Standard (AES)". FIPS 197, 2001(2023年更新). https://csrc.nist.gov/pubs/fips/197/final
- Dworkin, M. "Recommendation for Block Cipher Modes of Operation: The CMAC Mode for Authentication". NIST SP 800-38B, 2005(2016年更新). https://csrc.nist.gov/pubs/sp/800/38/b/upd1/final
- Dworkin, M. "Recommendation for Block Cipher Modes of Operation: Galois/Counter Mode (GCM) and GMAC". NIST SP 800-38D, 2007. https://csrc.nist.gov/pubs/sp/800/38/d/final
- Kelsey, J., Chang, S., Perlner, R. "SHA-3 Derived Functions: cSHAKE, KMAC, TupleHash, and ParallelHash". NIST SP 800-185, 2016. https://csrc.nist.gov/pubs/sp/800/185/final
団体・企業の資料
- ITU-T. "X.509: Information technology - Open Systems Interconnection - The Directory: Public-key and attribute certificate frameworks". 2019. https://www.itu.int/rec/T-REC-X.509, (参照2026-08-17).
- CA/Browser Forum. "Baseline Requirements for the Issuance and Management of Publicly-Trusted TLS Server Certificates". https://cabforum.org/working-groups/server/baseline-requirements/documents/, (参照2026-08-17).
- Mozilla. "Mozilla Included CA Certificate List". https://wiki.mozilla.org/CA/Included_Certificates, (参照2026-08-17).
- Google. "Chrome Root Program Policy, Version 1.8". https://www.chromium.org/Home/chromium-security/root-ca-policy/, (参照2026-08-17).
- デジタル庁. "マイナンバーカードに格納される公的個人認証サービスについて"(「公的個人認証サービス(JPKI)」ページ内の資料「電子証明書の種類」). https://www.digital.go.jp/assets/contents/node/basic_page/field_ref_resources/1f2fb150-febe-4bee-b691-f02f68c4e8d4/e376536f/20221219_private-businessjpki-introduction_outline_02.pdf, (参照2026-08-17).
- NPO法人日本ネットワークセキュリティ協会 電子署名ワーキンググループ. 『デジタル署名検証ガイドライン』第1.0版, 2021-03-31. https://www.jnsa.org/result/e-signature/data/e-signature-guideline_v1.0_20210331.pdf, (参照2026-08-17).
- Gueron, S. "Intel Advanced Encryption Standard (AES) New Instructions Set". Intel Corporation, Revision 3.0, 2010. https://www.intel.com/content/dam/doc/white-paper/advanced-encryption-standard-new-instructions-set-paper.pdf, (参照2026-08-17).
論文
- Diffie, W., Hellman, M. E. "New Directions in Cryptography". IEEE Transactions on Information Theory, vol. 22, no. 6, pp. 644-654, 1976. https://ee.stanford.edu/~hellman/publications/24.pdf
- Yao, A. C. "Theory and Application of Trapdoor Functions". 23rd Annual Symposium on Foundations of Computer Science, pp. 80-91, 1982. https://doi.org/10.1109/SFCS.1982.45
- Kelsey, J., Schneier, B., Wagner, D., Hall, C. "Cryptanalytic Attacks on Pseudorandom Number Generators". Fast Software Encryption, LNCS vol. 1372, pp. 168-188, 1998. https://doi.org/10.1007/3-540-69710-1_12
書籍
- 市原創, 板倉広明. 『SSL/TLS実践入門──Webの安全性を支える暗号化技術の設計思想』. 技術評論社, WEB+DB PRESS plusシリーズ, 2024.
- Ivan Ristić著, 齋藤孝道監訳. 『プロフェッショナルTLS&PKI 改題第2版』. ラムダノート, 2023.
記事
- Microsoft. "X.509 公開キー証明書". Microsoft Learn. https://learn.microsoft.com/ja-jp/windows/win32/seccertenroll/about-x-509-public-key-certificates, (参照2026-08-17).
- Microsoft. "基本フィールド". Microsoft Learn. https://learn.microsoft.com/ja-jp/windows/win32/seccertenroll/about-basic-fields, (参照2026-08-17).
- Microsoft. "バージョン 3 の拡張機能". Microsoft Learn. https://learn.microsoft.com/ja-jp/windows/win32/seccertenroll/about-version-3-extensions, (参照2026-08-17).
- トラスト・ソフトウェア・システム. "電子証明書のデータ形式". https://www.trustss.co.jp/smnDataFormat410.html, (参照2026-08-17).
- tex2e. "TLS 1.3/暗号化通信". 晴耕雨読, 2021-08-01. https://tex2e.github.io/blog/protocol/1-intro, (参照2026-08-17).
- tex2e. "TLS 1.3/プロトコルの概要". 晴耕雨読, 2021-08-01. https://tex2e.github.io/blog/protocol/2-protocol, (参照2026-08-17).
- tex2e. "TLS 1.3/基本的なデータ構造". 晴耕雨読, 2021-08-01. https://tex2e.github.io/blog/protocol/3-struct, (参照2026-08-17).
- tex2e. "有限体上の楕円曲線の点集合". 晴耕雨読, 2019-02-22. https://tex2e.github.io/blog/crypto/point-of-elliptic-curve-over-GF, (参照2026-08-17).
- tex2e. "有限体上の楕円曲線上のスカラー倍算". 晴耕雨読, 2019-02-23. https://tex2e.github.io/blog/crypto/elliptic-curve-scala-mul, (参照2026-08-17).
- tex2e. "サーバ名がIPアドレスの場合の証明書作成 / サブジェクト代替名 (SAN) の設定方法". 晴耕雨読, 2022-10-21. https://tex2e.github.io/blog/protocol/certificate-with-ip-addr, (参照2026-08-17).
- 市原創. "組み込み技術者向けTLS1.3基礎解説(後編):IoTでTLS1.3を活用すべき3つの理由". MONOist, 2018-10-10. https://monoist.itmedia.co.jp/mn/articles/1810/10/news005.html, (参照2026-08-17).
- Jxck. "HTTPS 証明書クロニクル". blog.jxck.io, 2026-03-23. https://blog.jxck.io/entries/2026-03-23/https-certificate-chronicle.html, (参照2026-09-20).
- Wikipedia. "Block cipher mode of operation". https://en.wikipedia.org/wiki/Block_cipher_mode_of_operation, (参照2026-08-17).
- Nuta, S. "Operating System in 1,000 Lines". https://operating-system-in-1000-lines.vercel.app/, (参照2026-10-15).
講演資料・ポッドキャスト
- catatsuy. "#11 Let's Encryptは無料より自動化がすごい!証明書運用の知られざる世界". 八百万のOSS(ポッドキャスト), 2026-07-14. https://podcasts.apple.com/cy/podcast/id1896371641?i=1000776773753, (参照2026-09-20).
- 大津繁樹. "TLS徹底演習". セキュリティ・キャンプ全国大会2016 集中講義, 2016-08-10. https://speakerdeck.com/shigeki/tlsche-di-yan-xi, (参照2026-09-20).
- 太田芽衣. "セキュアな通信のしくみを学ぼう". セキュリティ・ミニキャンプ in 大阪 2024 専門講座, 2024-03-23. https://www.security-camp.or.jp/minicamp/osaka2024.html.
ソースコード
- The Go Authors. "crypto/tls". Go標準ライブラリ. https://cs.opensource.google/go/go/+/refs/tags/go1.26.6:src/crypto/tls/, (参照2026-08-17).
図で使用したアイコン
- Computer icon created by Magnific - Flaticon
- Server icon created by Magnific - Flaticon
- Smart city icon created by gravisio - Flaticon
- Hub icon created by Chattapat - Flaticon
- Letter icon created by Magnific - Flaticon
- Padlock icon created by Magnific - Flaticon
- Key icon created by monkik - Flaticon
- Golden rule icon created by Magnific - Flaticon
- Label icon created by bqlqn - Flaticon
- Winner icon created by Magnific - Flaticon
- Thief icon created by Magnific - Flaticon
- British museum icon created by Magnific - Flaticon
イントロダクションの図で使用したロゴ
- 株式会社NTTドコモ. "NTTドコモ". https://www.docomo.ne.jp/, (参照2026-08-15).
- 楽天モバイル株式会社. "楽天モバイル". https://network.mobile.rakuten.co.jp/, (参照2026-08-15).
- KDDI株式会社. "KDDI株式会社". https://www.kddi.com/, (参照2026-08-15).
- ソフトバンク株式会社. "ソフトバンク". https://www.softbank.jp/, (参照2026-08-15).
- Amazon Web Services, Inc. "AWS". https://aws.amazon.com/jp/, (参照2026-08-15).
- Microsoft Corporation. "Microsoft Azure". https://azure.microsoft.com/ja-jp/, (参照2026-08-15).
- Alibaba Cloud. "Alibaba Cloud". https://www.alibabacloud.com/ja, (参照2026-08-15).
- Google LLC. "Google Cloud". https://cloud.google.com/, (参照2026-08-15).
- さくらインターネット株式会社. "さくらインターネット". https://www.sakura.ad.jp/, (参照2026-08-15).
- Google LLC. "Google". https://about.google/, (参照2026-08-15).
- Meta Platforms, Inc. "Meta". https://about.meta.com/, (参照2026-08-15).
- Netflix, Inc. "Netflix". https://www.netflix.com/, (参照2026-08-15).
- ByteDance Ltd. "TikTok". https://www.tiktok.com/, (参照2026-08-15).
- NTTドコモビジネス株式会社. "NTTドコモビジネス". https://www.ntt.com/, (参照2026-08-15).
- Lumen Technologies, Inc. "Lumen". https://www.lumen.com/, (参照2026-08-15).
- BBIX株式会社. "BBIX株式会社". https://www.bbix.net/, (参照2026-08-15).
- インターネットマルチフィード株式会社. "JPNAP". https://www.jpnap.net/, (参照2026-08-15).
- 株式会社JPIX. "株式会社JPIX". https://www.jpix.ad.jp/, (参照2026-08-15).
- Akamai Technologies, Inc. "Akamai". https://www.akamai.com/ja, (参照2026-08-15).
- Cloudflare, Inc. "Cloudflare". https://www.cloudflare.com/, (参照2026-08-15).
- Fastly, Inc. "Fastly". https://www.fastly.com/, (参照2026-08-15).
- NTT株式会社. "NTT". https://group.ntt/jp/, (参照2026-08-15).
- ソニーネットワークコミュニケーションズ株式会社. "So-net". https://www.so-net.ne.jp/, (参照2026-08-15).
- Space Exploration Technologies Corp. "Starlink". https://www.starlink.com/, (参照2026-08-15).
- JCOM株式会社. "J:COM". https://www.jcom.co.jp/, (参照2026-08-15).
- WIDEプロジェクト. "WIDE Project". https://www.wide.ad.jp/, (参照2026-08-15).
- 国立情報学研究所. "学術情報ネットワークSINET6". https://www.sinet.ad.jp/, (参照2026-08-15).
- Internet Assigned Numbers Authority. "IANA". https://www.iana.org/, (参照2026-08-15).
- Asia Pacific Network Information Centre. "APNIC". https://www.apnic.net/, (参照2026-08-15).
- 一般社団法人日本ネットワークインフォメーションセンター. "JPNIC". https://www.nic.ad.jp/, (参照2026-08-15).